今日美股網>技术指标>通达信公式>通达信副图指标:成交量主力,看真正的主力资金

通达信副图指标:成交量主力,看真正的主力资金

成交量主力
个股的资金情况,特别是主力资金的情况.这是通达信软件的真正的主力资金情况,需要L2数据。
如没收费L2行情,可以在本周搜索下载一个最新版开心果版本即可。
0轴以上,红色柱表示的是主力买入量,蓝色住是主力的卖出量;0轴以下,红色柱是主力的净买量,绿色柱是主力的净卖量。希望得到点赞。
副图源码如下:
{成交量主力,通达信副图}
万手:VOL/10000,LINETHICK0;
AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
预测:AA/10000;
主力买量:(L2_VOL(0,0)+L2_VOL(1,0))/10000,COLORRED,NODRAW;
主力卖量:(L2_VOL(0,1)+L2_VOL(1,1))/10000,COLORLIBLUE,NODRAW;
主力买:=L2_VOL(0,0)+L2_VOL(1,0);
主力卖:=L2_VOL(0,1)+L2_VOL(1,1);
散户买量:=L2_VOL(2,0)+L2_VOL(3,0);
散户卖量:=L2_VOL(2,1)+L2_VOL(3,1);
主力净量:(主力买量-主力卖量),COLORRED,NODRAW;
散户净量:(散户买量-散户卖量)/10000,COLORMAGENTA,NODRAW;
主力净:=主力买-主力卖;
{散户净:=散户买量-散户卖量;}
{今日美股網 WWW.GUCUAN.COM 整理}
持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORLIBLUE;
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED;
对应上涨家:INDEXADV,COLOR0080FF,NODRAW;
对应下跌家:INDEXDEC,COLORGREEN,NODRAW;
换手率:VOL/CAPITAL*100,NODRAW,COLORRED;
STICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.5,1),COLORWHITE;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,3.5,1),COLORRED;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,3.5,1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.5 , 0 ) , COLOR00FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.2 , 0 ) , COLOR007777 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.7 , 0 ) , COLOR009999 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.1 , 0 ) , COLOR00BBBB ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 1.5 , 0 ) , COLOR00DDEE ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.9 , 0 ) , COLOR66FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.2 , 0 ) , COLORFFFFFF ;
STICKLINE(主力卖>=0,0,主力卖,3.2,0),COLOR990000;
STICKLINE(主力卖>=0,0,主力卖,2.7,0),COLORCC0000;
STICKLINE(主力卖>=0,0,主力卖,2.1,0),COLORFF4400;
STICKLINE(主力卖<=0,0,主力卖,1.5,0),COLORFF8800;
STICKLINE(主力卖>=0,0,主力卖,0.9,0),COLORFFCC00;
STICKLINE(主力卖>=0,0,主力卖,0.2,0),COLORCYAN;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,3.2,0),COLOR000033;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,2.7,0),COLOR000066;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,2.1,0),COLOR000099;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,1.5,0),COLOR0000CC;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,0.9,0),COLOR0000FF;
STICKLINE(主力买>=0,主力卖,主力买+主力卖,0.2,0),COLORCC66FF;
STICKLINE(主力净<=0,0,主力净,3.2,0),COLOR003300;
STICKLINE(主力净<=0,0,主力净,2.7,0),COLOR006600;
STICKLINE(主力净<=0,0,主力净,2.1,0),COLOR009900;
STICKLINE(主力净<=0,0,主力净,1.5,0),COLOR00CC00;
STICKLINE(主力净<=0,0,主力净,0.9,0),COLOR00FF00;
STICKLINE(主力净<=0,0,主力净,0.2,0),COLORGREEN;
STICKLINE(主力净>=0,0,-主力净,3.2,0),COLOR000033;
STICKLINE(主力净>=0,0,-主力净,2.7,0),COLOR000066;
STICKLINE(主力净>=0,0,-主力净,2.1,0),COLOR000099;
STICKLINE(主力净>=0,0,-主力净,1.5,0),COLOR0000CC;
STICKLINE(主力净>=0,0,-主力净,0.9,0),COLOR0000FF;
STICKLINE(主力净>=0,0,-主力净,0.2,0),COLORCC66FF;
0;
五日: MA(V,5),COLOR40FF00;
三五日: MA(V,35),COLORYELLOW;
一三五日:MA(V,135),COLOR0080FF;
NOTEXT强:IF(五日>MA(五日,2),五日,DRAWNULL),COLORRED;
{今日美股網 WWW.GUCUAN.COM 整理}
{昨收:REF(CLOSE,1),NODRAW,COLORGREEN;
逐笔买卖差:(LARGEINTRDVOL-LARGEOUTTRDVOL)/10000,COLORBROWN,NODRAW;
主动买卖差:(ACTINVOL-ACTOUTVOL)/10000,COLORBROWN,NODRAW;}
超B:L2_AMO(0,0)/10000.0,NODRAW;
大B:L2_AMO(1,0)/10000.0,NODRAW;
超S:L2_AMO(0,1)/10000.0,NODRAW;
大S:L2_AMO(1,1)/10000.0,NODRAW;
主力净值:(超B+大B)-(超S+大S),NODRAW;
DAZHI:CONST(MAX(ABS(主力净值),MAX(ABS(超B),MAX(ABS(大B),MAX(ABS(超S),ABS(大S)))))),NODRAW;
DRAWRECTREL(0,0,175,999.4,IF(120,RGB(10,0,0),0));
DRAWRECTREL(0,CONST(830-(ABS(主力净值)*500/DAZHI)),30,935,IF(CONST(主力净值)>0,RGB(255,0,255),RGB(0,100,100)));
DRAWRECTREL(35,CONST(830-(ABS(超B)*500/DAZHI)),65,935,IF(CONST(超B)>0,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(70,CONST(830-(ABS(超S)*500/DAZHI)),100,935,IF(CONST(超S)>0,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(105,CONST(830-(ABS(大B)*500/DAZHI)),135,935,IF(CONST(大B)>0,RGB(100,0,0),RGB(0,50,0)));
DRAWRECTREL(140,CONST(830-(ABS(大S)*500/DAZHI)),170,935,IF(CONST(大S)>0,RGB(100,0,0),RGB(0,50,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.000,0.95,0,'净值'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.038,0.95,0,'超B'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0764,0.95,0,'超S'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.112,0.95,0,'大B'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.147,0.95,0,'大S'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,'今日主力买卖'),COLORYELLOW;{原为:今日分类持仓}
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.100,0,0,'单位(万元)'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.00,0.875,0,INTPART(主力净值)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.035,0.800,0,INTPART(超B)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.070,0.875,0,INTPART(超S)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.105,0.800,0,INTPART(大B)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.140,0.874,0,INTPART(大S)),COLORYELLOW;

友情提示:
1、本網站內容和圖片僅為個人學習、研究公益之用,如有侵權請聯系我們馬上處理。
2、本網站所刊載的所有信息僅供參考,不用做交易和服務的根據,且不構成任何投資建議。
3、領取福利,關註Twitter:https://twitter.com/TodayUSStock

相关内容